Heartbleed

April 23, 2014

Chances are you have heard about Heartbleed in the news. There are a lot of unanswered questions, but the bottom line is, you need to take action right now.

This problem only affects certain websites that use a certain security product called OpenSSL. If a website you have used is on the list of websites that were vulnerable to Heartbleed, then you should go and change your password on that website ASAP.

Below is a link to the list of websites. Please check it and change your password on any websites you use. While you are at it, it’s a good idea to change your password on critical websites from time to time anyway. So why not go ahead and change those passwords now while you are thinking about it. By critical websites, I am referring to Financial institutions, email, and other sites that contain sensitive or critical information about you or your finances.

Here’s the link: http://mashable.com/2014/04/09/heartbleed-bug-websites-affected/

 

Leave a Reply

You must be logged in to post a comment.